Can’t login to SharePoint 2013 site when using Host Header in webapplication

By creating a new partner portal for our partners I wanted to use the new SharePoint Server 2013 as platform.

image

When I created a new Web Application, I set the host header to “partner.solutions2share.intern”. Before you create your new Web Application, you have to make sure that a DNS record is created and pointed to your SharePoint Server.

image

My environment is set up with three Windows 2012 Enterprise Editions. One server is configured as the Domain Controller, the other is configured as Database Server with SQL Server 2012 and my Web-Front-End Server with SharePoint 2013.

My problem

After creating my new Web Application and a new SiteCollection with the url “partner.solutions2share.net” I tried to access my new site.
But there is a problem with the login. After three tries to access the site I only got a blank site.

The solution

You have to add a new Multi-String registry key named “BackConnectionHostNames” in SharePoint server at HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlLsaMSV1_0 and set the host names with values (for example “partner.solutions2share.intern).

image

  1. Start, click Run, type “regedit”, and then click OK.
  2. Locate the following registry key: HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlLsaMSV1_0
  3. Right click on MSV1_0, go to New, and then click Multi-String Value.
  4. Type “BackConnectionHostNames”, and then press ENTER.
  5. Right click on the value “BackConnectionHostNames”, and then click Modify.
  6. In the “value data” box, type the host names (for example “partner.solutions2share.intern”) for the sites, and then click OK.
  7. Quit Registry Editor, and then run an iisreset

Finally navigate to your URL and it will work.

MSDN Reference : http://support.microsoft.com/kb/896861/en-us